Главная - Без рубрики - Плагин Canonical можно не использовать

Плагин Canonical можно не использовать

Начиная с версии WordPress 2.9 этот плагин потерял свою актуальность.

Если у вас еще стоит Вордпресс младше и вы до сих пор не обновились и не собираетесь это делать, вы можете вместо плагина просто вставить код в файл header.php:

<?php if ( is_singular() ) echo '<link rel=&quot;canonical&quot; href=&quot;' . get_permalink() . '&quot; />';

Начиная с версии 2.9 — это уже делает сам Вордпресс. Если вы хотите отключить эту функцию — тогда в файл functions.php вашего шаблона добавьте такой код:

remove_action( 'wp_head', 'rel_canonical' );

Но я бы вам это делать не советовал.

О admin

2 комментария

  1. мда, еще бы знать нафига он нужен…

Оставить комментарий

Ваш email нигде не будет показанОбязательные для заполнения поля помечены *

*